ALGORITMOS


-???-

Pseudocodigos



• Los DF son un método de representación algorítmica funcional pero limitado.
• Se necesita de una herramienta que permita detallar los procesos representados por dichos diagramas.
• Etimológicamente, pseudocódigo significa falso código.
• La razón más importante para hacer uso del pseudocódigo es que con ellos se logra independencia del lenguaje de programación.
• Al ser un modelo adaptable al usuario, permite acostumbrarse a la Gramática y Sintaxis de un lenguaje.
• A nivel pseudocódigo, todo algoritmo se compone de:

– inicio
– Encabezado
– Sección de declaraciones
– Cuerpo del algoritmo
• Entrada
• Sección de subalgoritmos
• Impresión de resultados
– Fin

EJEMPLO 1
Escriba el pseudocodigo que permita calcular e imprimir el cuadrado y el cubo de un número entero positivo.cuadrado_cubo

/*algoritmo que imprime el cuadrado y el cubo de unintroducido por teclado*/
VARIABLES
numero, cuadrado, cubo
INICIO
Escribir(“Este programa calcula el CUADRADOEL CUBO de un NUMERO: ”)
Escribir(“Ingrese un número entero”)
Leer (Numero)
Hacer
Cuadrado= numero*numero
Cubo= numero*numero*numero
Escribir(cuadrado, cubo)
FIN ALGORITMO cuadrado_cubo

EJEMPLO 2
Construya un diagrama detal que dado los datosA y B, escriba elde la siguienteón. Trasládela aódigo. (A + B)**2/3

ALGORITMO expresion
/*Algoritmo que calcula el resultado de unaón dada*/
VARIABLES
Entero: A, B
Real: resultado
Escribir(“Ingrese el valor de A”)
Leer (A)
Escribir(“Ingrese el valor de B”)
Leer(B)
resultado=(A+B)**2/3
escribir (resultado)
FIN ALGORITMO expresion




-???- | -???-